Запускаем Eagle 6.10 в Ubuntu 10.04



Установка Eagle на Windows системы не вызывает проблем, а вот на Linux не всегда проходит гладко. Проблема при установке Eagle Cad (в моем случае версии 6.1.0) на Ubuntu (10.04) заключается в отсутствии библиотек libpng14.so.14, libjpeg.so.8, libssl.so.1.0.0, libcrypto.so.1.0.0

Был найден следующий выход из положения:


wget ftp://ftp.cadsoft.de/eagle/program/6.1/eagle-lin-6.1.0.run
sed -e '1,/^__DATA__$/d' eagle-lin-6.1.0.run > eagle-lin-6.1.0.tar.bz2
tar xvjf eagle-lin-6.1.0.tar.bz2
cd eagle-6.1.0/bin

wget http://dl.dropbox.com/u/32664487/eagle_libs.tar.bz2
tar xvjf eagle_libs.tar.bz2
mv eagle eagle.orig
echo 'LD_LIBRARY_PATH="$(dirname "$0")" "$(dirname "$0")/eagle.orig" $@' > eagle
chmod a+x eagle

Далее по желанию делаем ярлычек на файл eagle:
gnome-desktop-item-edit --create-new ~/Desktop

Все библиотеки лежат в папке bin.
Кого не удовлетворяет данный однокнопочный способ может почитать следующие авторитетные издания:

Arduino, MK-90 и другие
Joe Desbonnet's web log.






Комментарии